CentOS 8中安装Docker出现和Podman冲突

最近更新时间 2020-02-23 10:51:42

在安装 Docker 时出现如下错误信息:

file /usr/share/man/man1/docker-attach.1.gz from install of docker-ce-cli-1:19.03.6-3.el7.x86_64 conflicts with file from package podman-manpages-1.4.2-5.module_el8.1.0+237+63e26edc.noarch

是因为系统中已经安装了 Podman

1. 查看是否安装 Podman

rpm -q podman
podman-1.4.2-5.module_el8.1.0+237+63e26edc.x86_64

2. 删除Podman

dnf remove podman

3. 安装 Docker 

dnf install docker-ce docker-ce-cli
可能喜欢
最近浏览
正在加载浏览记录