ECMAScript 5浏览器兼容性

最近更新时间 2020-01-10 11:24:06

ECMAScript是一种由Ecma国际在标准ECMA-262中定义的脚本语言规范。

ECMA-262第5版于2009年12月发布,新增 "严格模式(strict mode)",一个子集用作提供更彻底的错误检查,以避免结构出错。

除此而外,还有 Function.prototype.bind、数组方法 indexOfforEachmapfilter,对象方法 definePropertycreatekeys等新特性。

浏览器支持情况如下所示:

IE8
不支持。但支持 Object.defineProperty、Object.getOwnPropertyDescriptor 和 JSON解析等功能。
IE9
部分支持。不支持严格模式(Strict mode)
IE10+
支持。发布时间:2012年。
Firefox 21
支持。发布时间:2013年。
Chrome 23+
支持。发布时间:2012年。
Safari 6+
支持。发布时间:2012年。
IOS Safari 6+
支持。发布时间:2013年。
Android Browser 4.1-4.3
部分支持。存在parseInt()函数问题
Android Browser 4.4+
支持。发布时间:2013年。
Chrome for Android 79+
支持。发布时间:2019年。
可能喜欢
最近浏览
正在加载浏览记录